TYPO3 / GraphicsMagick: Rotstich bei Bildern beheben (Farbfehler)

Hier mal wieder ein kurzes Snippet. Bedauerlicherweise kann man sich bei manchen Projekten leider den Hostingdienstleister nicht aussuchen und muss mit dem Server klarkommen, welchen man zur Verfügung gestellt bekommt. Dabei ist manchmal nicht mal eine vernünftige PHP Version gegeben und man muss erstmal drei Tage telefonieren oder ein Hostinganbieter bringt Joomla und TYPO3 einfach mal durchereinander ^_^

Neulich war ich mal wieder mit so einem Horrorserver konfrontiert. Nachdem irgendwann endlich mal TYPO3 in Ansätzen funktioniert hat fiel auf, dass alle Bilder einen krassen rotstich hatten. Manche Bilder waren nicht neben rot auch einfach mal total blau, gelb oder grünlich – ja fast CMYK. Irgendetwas musste also mit der Bildverarbeitung durch ImageMagick oder GraphicsMagick nicht in Ordnung sein – aber probiert ein solches Problem mal zu googeln…

Letztendlich habe ich die Lösung für meinen Fall gefunden. Ich musste GraphicsMagick im Installtool unter [GFX][im_stripProfileCommand] mit folgendem Befehl erstmal anweisen RGB zu verwenden:

-set colorspace RGB +profile ‚*‘

 

In Kraft treten tut diese neue Konfiguration jedoch erst beim erneuten rendern der Bilder durch TYPO3. Dieses kann man beschleunigen indem man im Installtool unter „Clean Up“ die Funktion „Clear processed files“ nutzt, wodurch alle Bilder aus dem Ordner fileadmin/_processed entfernt werden und neu generiert werden müssen.

 

3 Kommentare

Schreibe einen Kommentar zu Paul Beck Antworten abbrechen

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.

Highlighting von Codes ist mit den Tags  [ts], [php], [html], [javascript], [xml] oder [code] möglich.