PhpStorm (Version 2016) – SFTP mit Passphrase

Ich habe heute versucht in PhpStorm eine SFTP Verbindung mit Key Authentifizierung einzurichten. Der Key war neu generiert und mit einer Passphrase geschützt. Um so größer war dann mein staunen als ich bei dem ersten Versuch folgende Fehlermeldung von der IDE angezeigt bekommen habe:

Server ‚Check‘ is not valid: Keypair ‚PFAD zur Datei‘ is corrupt or has unknown format. Only SSH2 keys in OpenSSH format or PuTTY Private Key *.ppk keys are supported. Error message: The cipher ‚aes256-cbc‘ is required, but it is not available.

Das ganze konnte ich lösen in dem ich mir folgende Dateien http://www.oracle.com/technetwork/java/javase/downloads/jce8-download-2133166.html geladen habe und die vorhandenen unter PhpStormROOT/jre/jre/lib/security ersetzt habe. Erst dann steht die nötige „Cryptography Extension“ JAVA bzw PhpStorm zur Verfügung, diese ist benötigt um mir der Passphrase arbeiten zu können.

Ich hoffe ich konnte helfen 🙂

Gruß Olli

//EDIT
Weitere Lösungsweg im Kommentar http://blog.teamgeist-medien.de/2016/07/phpstorm-version-2016-sftp-mit-passphrase.html#comment-392 zu finden.
Vielen Dank an
Henrik Ziegenhain

2 Kommentare

Schreibe einen Kommentar zu Oliver Pfaff Antworten abbrechen

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.

Highlighting von Codes ist mit den Tags  [ts], [php], [html], [javascript], [xml] oder [code] möglich.